Degraded performance on app

Incident Report for nuwacom platform

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 15:25 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2026 - 14:38 CET

Identified

Update: The issue still persists and our engineering team is working with high priority on a fix.
Posted Mar 27, 2026 - 09:58 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 23:29 CET

Identified

The issue has been identified and a fix will be rolled out
Posted Mar 24, 2026 - 16:26 CET

Investigating

We identified slow app response while working with nuwacom. Our team is investigating this issue.
Posted Mar 24, 2026 - 16:20 CET
This incident affected: Core API.